Set Up Data Sources

Connect Data on the Template


Are you looking for a solution that allows your end-users to quickly implement publications with fixed structured content (e.g., business cards, flyers, or addresses)? Thanks to our ‘External Data Sources’ functionality, you can do that!

This help article explains how you can set up these external data sources and connect them to your templates. Currently, CSV files and (public) Google Spreadsheets are supported.

The great advantage of this feature is that it allows you to link different layers (text and images) to each other and to a table. That enables you to customize multiple content elements in a single step. For example, in the case of a business card, you can select and customize the name, function, address, email address, and phone number in a single step.

Add/Edit/Delete Your Data Source

You can add, edit or delete your sources by navigating to the "Data Sources" section in the Template Library Settings. For adding your first source, go to the button "New Data Source", which you click. Select your desired Source type: CSV or Google Spreadsheet.

You can add, edit or delete your sources by navigating to the "Data Sources" icon in the Power Bar. For adding your first source, go to the button "New Data Source", which you click. Select your desired Source type: CSV or Google Spreadsheet.

CSV File

Add

Upload your desired CSV file. If the data check is successful, i.e., the file does not contain any obvious data errors, you can give your source a meaningful name (you will need it later to assign your source to a group) and add your CSV file as a source.

Edit

If you want to edit your source (e.g., to update the data), click on the source and select "edit". Then click on the CSV File you want to edit, click 'Replace' and upload your new file. Confirm your selection to update the source on the templates.

The source will be updated wherever you use it. You don’t need to change anything in your Data Groups or linked layers on templates. Ensure the same columns present as in the original source - especially if the source is already in use.

There are links to the templates using this source when editing it.

Delete

If you want to delete a source, click on the source and select "Delete". If the source is still in use on one or more templates, you cannot delete it; you must first delete your connections in the templates. If your source is not linked to any group, you can delete it.

Google Spreadsheet:

Add

Add the link to your Google spreadsheet.

Be aware: The google Spreadsheet needs to be publicly accessible (set this over “File” - “Share” - “Publish to Web”).

As soon as the link gets accepted, you can give your source a meaningful name (you will need it later to assign your source to a group) and add your Spreadsheet as a source.

Edit

Click on the source and select "edit" if you want to edit it. Then add your new spreadsheet link under “Google Sheet URL”. Confirm your selection. Only when you confirm, the source will be updated on the templates.

There are links to the templates using this source when editing it.

Please note: If you want to change content on your Google Spreadsheet, you can do this directly in your sheet without updating the source.

Be aware: you are responsible for not breaking your spreadsheet by, e.g., deleting columns that are actually in use in a template.

Delete

If you want to delete a source, click on the source and select "Delete". If the source is still in use on one or more templates, you cannot delete it; you must first delete your connections in the templates. If your source is not linked to any group, you can delete it.

Data Requirements for Data Sources

Please note the following requirements/notes for your data sources:

  • Each column needs a header cell.

  • Each column header must appear only once.

  • You can add line breaks in a cell in your CSV sheet.

Data Group

A data group serves as a container for all information on a template that is to be replaced together in one step.

For example, if you want to replace in one single step the name, surname, and address in the business card, these 3 elements are part of the same data group, and you need to link this data group to each layer of your template you want to fill in with this information, and then pick up the right column of the file for each layer (name or surname or address).

It is possible to have several data groups per template on which you can use the same or different data sources.

Suppose you want to replace three different addresses on a template with external data. In that case, you need three data groups connected to the same source (the different addresses available for selection). The three groups allow the end-user to select the three addresses in 3 steps on the same publication (picking information from the same table). Please note: There’s only one source per group possible.

This one or multiple data groups are also visible to the end-user on the publication, so pick a name for your data group that makes sense to end-users.

Add your Data Group

Before you can start linking your layers to your data group in your template, you need to create this data group. You can do this by clicking on the “Data” tab on the left side (next to “Pages” and “Layers”) in the selected template.

GIF showing how to add a Data Group to your templae
  1. Click “New Data Group”

  2. Pick the Data Source you previously uploaded and give your group a meaningful name and (optional) description. This group name and description will be displayed to your end-users.

  3. Save your choice. You have now added your Data Group and can start linking your layers to your group.

Edit Data Group

You can edit your Data Group by clicking on the three dots on the right side of the Group in the Data tab. You can change the name of your group or pick a different Data Source for your group. If you change your Data Source, choose one containing the same columns as the previous one.

Delete Data Group

Delete your Data Group by clicking on the three dots at the right of your Group and picking "Delete". Please be aware: you can only delete a Data Group that hasn't any connections to layers.

Link Layers to Data Group

To connect a text layer or an image to a Data Group, click on the link icon next to the lock icon at the top of your settings.

Pick your Data Group and the column you want to link from the Data Source. That’s already it. You now linked your layer to the group.

If you want to disconnect your layer, click on the link icon again and press “Disconnect”.

In the “Data” tab on the left side, you can see all your connected layers. By clicking on the item in this list, you activate the layer, allowing you to access the “connect” options directly.

Use of Placeholders

If you want to connect part of a text field to a column in your data, you can use our placeholders. You can access the placeholders by selecting the text snippet you want to replace with the data value, and then connecting it to your data group in the same way you do with whole text fields.

Make sure that the text part you select has only one style and is in one line only (e.g. no different colour, font size or similar).

If your placeholder needs some conditional removal behavior (e.g. if the placeholder value is missing in the table, then remove a comma and a space), you can add this in the placeholder's settings. You can choose between removing some characters or removing a line break.

In case you'd like to allow manual content changes on your placeholder after applying data from the table, click on the "unlock" icon close to the link icon.

Please note that you should not modify or delete your placeholder text snippets after you have connected them. If you need to change the placeholder's content, please make sure that you disconnect the placeholder first.

If you have any questions please don't hesitate to contact us.

Did this answer your question?