Supported Browsers

For an optimal app experience, better encryption, and privacy support, we recommend using the latest versions (current and previous major releases) of the browsers listed below.

Important: Using older browser versions can prevent you from accessing Frontify, and some app features may not function as expected.

We support the current and previous major releases of the following desktop browsers:

HTML5 capable browser

  • Microsoft Edge (current and last major revision)
  • Firefox (current and last major revision)
  • Chrome (current and last major revision)
  • Safari (current and last major revision)
  • Internet Explorer 11*

*Note: As of March 31, 2021, we will no longer support Internet Explorer 11 (or below) and your Frontify experience may be suboptimal. We recommend moving to one of the above browsers as soon as possible for the best experience.

Recommendation: 

Permanent Internet connection
Javascript has to be turned on
Cookies enabled

No ad blocker / adGuard active
No browser restrictions for Frontify Application

If you are using a current version of a supported browser and an app feature still doesn't work as expected:

  • Determine if your internet browser is current or needs upgrading.
  • Try using a different browser (in its latest version) as a temporary workaround.

If you've tried these solutions but continue experiencing issues, contact us with the following details:

  • An explanation of the issue
  • The browsers and versions you've tried
  • A screenshot of your issue

Did this answer your question?